Difference between revisions of "Jmol Applet/ja"

From Jmol
Jump to navigation Jump to search
(Translated from Jmol Applet version 2010/5/22 Sat 00:29 (UTC) written by NicolasVervelle, AngelHerraez, Pimpim, Gutow, Gutow etc.)
 
m (fixing wrong characters due to change in charset during migration of the wiki; text recovered from the old server)
 
(10 intermediate revisions by one other user not shown)
Line 1: Line 1:
 
{{Lang:Jmol Applet}}
 
{{Lang:Jmol Applet}}
  
{{Running_Jmol_Sections}}
+
{{Running_Jmol_Sections/ja}}
  
== Jmolアップレット ==
+
== Jmol オブジェクト ==
[[wikipedia:Java_applet|Javaアップレット]]版のJmolを使うと、ウェブページにJmolを埋め込むことができます(Javaプラグインがインストールされたブラウザで見ることができます)。スタンドアロン版と同様に、[[Scripting|スクリプト]]を使うことができます。例をいくつかデモページ http://www.jmol.org/demo/ に挙げてあるので参照して下さい。ウェブブラウザでHTMLソースを見るには、Firefoxの場合 {{MenuItem|表示}} → {{MenuItem|ページのソース}} をクリックして下さい。
 
  
== Jmolアップレットのインストール ==
+
=== Jmolアップレット ===
{{Installing_Jmol_Sections}}
+
[[wikipedia:Java_applet|Javaアップレット]]版のJmolを使うと、ウェブページにJmolを埋め込むことができます(Javaプラグインがインストールされたブラウザで見ることができます)。スタンドアロン版と同様に、[[Scripting|スクリプト]]を使うことができます。例をいくつかデモページ http://www.jmol.org/demo/ に挙げてあるので参照して下さい。ウェブブラウザでHTMLソースを見るには、Firefoxの場合 {{MenuItem|表示}} → {{MenuItem|ページのソース}} をクリックして下さい。
Jmolパッケージ(圧縮形式は <code>.zip</code> 、<code>tar.gz</code> どちらでも構いません)をダウンロードし、'''必要なファイルだけを'''あなたが選んだフォルダに解凍して下さい。
 
  
どれが必要なファイルなのでしょう? 基本的な使い方をするのに必要なファイルは以下の通りです。
+
=== Jmol HTML5オブジェクト(JSmol) ===
* {{File|Jmol.js}}、このファイルにはウェブページを通してJmolとやりとりを行う助けになるコマンドを生成する一連のスクリプトが含まれています。機能の概要については[http://jmol.sourceforge.net/jslibrary/ オンラインドキュメント]を見るか、あるいは Jmol.js ファイルのソースを見てより最新の情報を得ることができます。
+
バージョン13.1から、JSmolと呼んでいる非Java版Jmolを使ってJmolをウェブページに埋め込むことができるようになりました。
* ファイル名が {{File|JmolApplet0}} で始まり、{{File|.jar}} で終わる全てのファイル。
+
これによりJavaScriptだけを用いるHTML5オブジェクトが使ってJmolアップレットと同等の機能が実現できます。
ウェブページを配布するのであれば、著作権等に関するファイル({{File|COPYRIGHT.txt}}、{{File|LICENSE.txt}}、{{File|README.txt}})も含めておくのがいいでしょう。
+
詳しくは[[Jmol JavaScript Object/ja|Jmol JavaScriptオブジェクト]]([[Jmol JavaScript Object|英語版]])を参照して下さい。
  
ローカルのウェブページでJmolアップレットを使う(例:ハードディスクやCDで利用する)にはいくつか注意事項があります。それについては[[Jmol Applet Deployment Local]]を参照して下さい。
+
== Jmolオブジェクトのインストール ==
 +
Jmolによる分子画像をウェブページに組み込みたいだけであれば、テストページ作りから始めるよりも簡単な方法があります。
 +
[[#Tools for Authoring Jmol Web Pages|Jmolウェブページを作るためのツール]]を参照して下さい。
 +
Jmolを埋め込んだウェブページを作成する方法を知りたいのであれば、右記「Jmolをインストールする」を参照して下さい。
  
その他特別必要なものについては、別のファイルを使う必要があります。署名済みアップレットについては以下の節を読んで下さい。
+
{{Installing_Jmol_Sections/ja}}
  
アップレットがロードされない場合は[[Solving Java Problems|Java問題の解決]]も参照して下さい。
+
Jmolパッケージ(<code>.zip</code>版、<code>tar.gz</code>版どちらでも構いません)をダウンロードし、解凍・展開して、'''必要なファイルだけ'''を使って下さい。
  
=== Jmolアップレットにより多くのメモリを割り当てる ===
+
どのファイルが必要なのかについては、以下をご覧下さい。
Jmolが利用できるメモリ量はJavaによって決められています。現在のメモリ割り当てはアップレットのポップアップメニューの一番下にある「About Jmol」をポイントすることで確認できます。
 
  
以下のパラメータを使って割り当てメモリ量を変更できます:
+
ローカル環境(ハードディスクやCD)のウェブページでJmolアップレットを使う場合、あらかじめ注意しておくべき点がいくつかあります。[[Jmol Applet Deployment Local/ja|Jmolアップレットをローカルで開発する]]([[Jmol Applet Deployment Local|英語版]])を参照して下さい。
 +
 
 +
場合によっては別のファイルを使う必要があります。以下に記している署名付きアプレットについてをお読み下さい。
 +
 
 +
アップレットが起動しない場合、[[Solving Java Problems/ja|Javaに関する問題の解決策]]([[Solving Java Problems|英語版]])を参照下さい。
 +
 
 +
ウェブページを配布する場合、以下に記す著作権、許諾条件、諸情報を記したファイルを含めておく必要があります。
 +
* {{File|COPYRIGHT.txt}}
 +
* {{File|LICENSE.txt}}
 +
* {{File|README.txt}}
 +
 
 +
=== ウェブページにJmolオブジェクトを埋め込む ===
 +
 
 +
JavaScriptをベースとした2つの方法を使うと簡単にJmolアップレット・オブジェクトをウェブページに埋め込み、管理することができます。
 +
 
 +
 
 +
==== Jmol JavaScript オブジェクト(Jmol-JSO) ====
 +
'''Jmol-JSO'''(Jmolバージョン13で新たに導入されました)を使うと、きれいで効率的な方法でJavaScriptからJmolアップレットを操作することができます。
 +
更にJavaやアップレットの利用に制約があるiPad、iPhone、Androidモバイル端末などでも利用できるほか、Jmol Javaアップレットが使えない環境であっても[http://rcsb.org RCSB PDBデータベース]、[http://cactus.nci.nih.gov/ アメリカ国立がん研究所のCACTVSサーバ]、[http://pubchem.ncbi.nlm.nih.gov/ PubChem]などの公開データベースへ簡単にアクセスできます。
 +
 
 +
これにはJavaに代わる基本的で高機能なスクリプト機能が備わっています。更に、'''Jmol-JSO'''を使うことにより[http://jspecview.sourceforge.net JSpecViewアップレット]や[http://www.molinspiration.com/jme JMEアップレット]による2次元-3次元モデル構築・相互変換と同期する機能も付加することができます。
 +
 
 +
詳しくは[Jmol JavaScript Object/ja|Jmol JavaScriptオブジェクト]([Jmol JavaScript Object|英語版])を参照して下さい。
 +
 
 +
==== Jmol.jsライブラリ ====
 +
'''Jmol.js'''はJmolバージョン12用のライブラリ(使おうと思えばバージョン13でも使うことはできます)で、ボタン、チェックボックス、リンク、メニューのような対話操作機能を含むウェブページを素早く構築できるようにする一連のスクリプトコマンドを提供します。
 +
 
 +
Jmol.jsに実装された全ての機能は'''Jmol-JSO'''でも実装されています。
 +
これら機能の概要については[{{Website}}jslibrary/ja Jmol.jsオンラインドキュメント]、あるいは最新の情報が掲載されている Jmol.js のソースファイルを参照して下さい。
 +
 
 +
''注:'' {{file|Jmol.js}}はJmolバージョン13より段階的に廃止され、新たなオブジェクト指向JavaScriptと{{file|.js}}ファイルを用いた方法に移行します(詳細は次節)。またJmolバージョン13.2以降の'''ダウンロードコンテンツ'''にはJmol.jsに関連するファイル群は'''含まれません'''。引き続き利用したいのであれば、別途[{{SVN Trunk}}Jmol/appletweb/old/Jmol.js Jmolレポジトリ]から入手して下さい。特に2014年1月から、'''Javaの新たなセキュリティポリシーによって古いバージョンの{{file|Jmol.js}}は機能しなくなります'''。もしウェブサイトを[[Jmol_JavaScript_Object/ja|Jmol-JSOを使ったもの]]([[Jmol_JavaScript_Object|英語版]])に移行できないか、あるいは[[Jmol_JavaScript_Object#Conversion_using_the_Jmol2.js_.27adapter.27_library|移行期間用のアダプタJmol2.js]]を使うのであれば、新しいJmol.jsを[{{SVN Trunk}}Jmol/appletweb/old/Jmol.js?format=raw ダウンロード]して既存のJmol.jsファイルを置き換える必要があるでしょう。
 +
 
 +
=== JmolアップレットJARファイル ===
 +
Jmol-JSOもJmol.jsも共にJavaScriptライブラリを使っていますが、Jmolをアップレットとして実装するには4種類の方法があります。
 +
 
 +
* '''単一の非署名アップレットを使う方法''' {{file|JmolApplet.jar}}だけを使ってウェブサイトを構築するというやり方です。Jmol.jsを使う場合は、アップレットは同一サイト内のファイルにのみアクセスします。Jmol-JSOを使う場合は、同一サイト内のファイルに加え公開データベースのファイルにもアクセスします。
 +
 
 +
* '''非署名アップレットモジュール群を使う方法''' {{file|JmolApplet0.jar}}とそれに関連するファイル(全部で54個の{{file|jar}}ファイルがあります)をウェブサイトに使います。ファイル数は多くなりますが、最初にダウンロードされるのはJmolの必要な部分だけであるという利点があります。ダウンロードされていない部分は必要に応じ追加ダウンロードされます。この方法だとアップレットの起動がより速くなります。
 +
 
 +
* '''単一の署名済みアップレットを使う方法''' {{file|JmolAppletSigned.jar}}は署名済みJmolアップレットで使う全ての機能を実装した単一のファイルで、ファイルサイズは2.5MB以上ある大きなものです。この署名済みアップレットを使うとより多くの機能が使えるようになり、異なるドメインへのファイルにアクセスしたり、ユーザのローカルハードディスクにファイルを転送したりといったことができるようになります。
 +
 
 +
* '''署名済みアップレットモジュール群を使う方法'''
 +
{{file|JmolAppletSigned0.jar}}およびこれに関連するファイル(JmolApplet0.jarなど)を使って、必要なモジュールだけをユーザのブラウザに転送することができます。署名済みアップレットを使う場合、この方法を推奨します。
 +
 
 +
=== Jmolアップレットにより多くのメモリを割り当てて動作させる方法 ===
 +
 
 +
注:これはJmol.js(<code>jmolSetMemoryMb(nMb)</code>)でもJmol-JSO(Info.memoryLimit = nMb)でも行うことができます。
 +
 
 +
Jmolが利用できるメモリ量はJavaによって決められています。アップレットのポップアップメニューを開き、一番下にある「Jmolについて」から現在のメモリ割り当て量を確認することができます。
 +
 
 +
以下のパラメータにより割り当てメモリ量を増減することができます。
 
  -Xmx###M
 
  -Xmx###M
<nowiki>###</nowiki> には割り当てメモリ量をMB単位で指定します(そのため最後には "M" の文字をつけます)。但し割り当て可能なメモリ量はウェブクライアントマシンに装着されたRAMの量によって制限されます。例えば、512MBのRAMを搭載したシステムでは最大256MBまでしかJavaに割り当てることができません。
+
<nowiki>###</nowiki>にはメガバイト単位の数値を指定します(この例の場合、後ろに「M」を付けているので)。但し、割り当てることのできるメモリ量はシステムに実装されている物理メモリ量によって制限されます。例えば、システムに512MBのRAMがある場合、Javaが割り当てることのできるメモリ量は最大256MBです。
 +
 
 +
例:
 +
* -Xmx512M  最大512MBのメモリが利用可能
 +
* -Xmx1024M    最大1024MBのメモリが利用可能
 +
 
 +
このパラメータの設定位置はシステムによって異なります:
 +
 
 +
====Windows====
 +
*コントロールパネル > Javaアイコン([[Solving_Java_Problems/ja#Java_Control_Panel|Javaコントロールパネル]]([[Solving_Java_Problems#Java_Control_Panel|英語版]])が開く) > 「Java」タブ > 「アプレット ラインタイム設定」 > 「表示」ボタン > 「JRE」行(複数行ある場合はバージョンが最も新しいもの)をクリックし、「パラメータ」のテキストボックスに「-Xmx###M」と入力する。
 +
 
 +
====Macintosh====
 +
* OS 10.5 (Leopard): /アプリケーション/ユーティリティ にある JavaPreferences.app をダブルクリック。「全般」タブでリストの最初にあるバージョンのJavaを選択し、有効になった「オプション」ボタンをクリック。「アプレット ランタイムパラメータ」が開く。ここにパラメータ「-Xmx###M」を入力。
 +
* OS 10.4 (Tiger): /アプリケーション/ユーティリティ/Java/J2SE 5.0/Java Preferences を開いて、「-Xmx###M」を入力する箇所を探して下さい。
 +
[[Solving_Java_Problems/ja#Java_Control_Panel|Javaコントロールパネル]]([[Solving_Java_Problems#Java_Control_Panel|英語版]])も参照して下さい。
 +
 
 +
これはローカルマシンの設定について記していて、その設定を行ったコンピュータにしか変更は反映されません。ウェブページを閲覧するユーザが同じJavaメモリ設定を行っているとは限りません。メモリ割り当て量を変更する時はこの点に注意して下さい。
 +
 
 +
技術的詳細情報:
 +
* -Xmx は利用可能な最大メモリサイズを設定します。
 +
* -Xms は利用可能な最小メモリサイズを設定します。
 +
 
 +
[[Jmol_Application/ja#Giving_Jmol_more_memory_to_work_with|アプリケーションのメモリ取り扱いについて]]([[Jmol_Application#Giving_Jmol_more_memory_to_work_with|英語版]])もご覧下さい。
 +
 
 +
 
 +
===  Jmolアップレットをある特定の言語で表示させる ===
 +
Jmolアップレットではユーザインタフェース(ポップアップメニュー)に利用できる言語を複数備えています(技術的にはこのことを現地語化 localization と呼んでいます)。
 +
初期状態では、OSで使用されている言語([http://java.sun.com/j2se/corejava/intl/reference/faqs/index.html#set-default-locale 参考])がアップレットのインタフェースに適用されます。これを変更する方法は以下の通りです。
 +
 
 +
# Jmol 11.1.30以降、アップレットの使用言語はいつでも変更できるようになりました。言語はポップアップメニューの下方にある「言語」から変更できます。
 +
# 表示言語はスクリプト言語を使って変更することもできます。例:<code> language = "de" </code>(「language」というキーワードと言語を示す2文字コードで指定します。言語コードはca, cs, de, en, es, et, fr, ja, nl, pt, trなどが利用できます)。
 +
 
 +
 
 +
=== 異なるアップレットのバージョンを試す ===
 +
''(これは上級者向け機能です)''
 +
 
 +
任意のウェブページ(自身が管理しているページでなくても構いません)に埋め込まれたJmolアップレットを強制的にある特定のバージョンで動作させることができます。
 +
その方法は以下の通りです。
 +
 
 +
利用しようとしているJmolのjarファイル({{file|JmolApplet0.jar}}または{{file|JmolAppletSigned0.jar}})を示すURLの末尾に以下の文字列を追記します。
 +
?JMOLJAR=
 +
もし既にURL中に<code>?</code>が存在する場合は、代わりに<code>&JMOLJAR=</code>を追記して下さい。
 +
 
 +
いくつか警告が表示され、許可するよう求められるでしょう。これは全く関係のないサーバにある別のアップレットと置き換えられてしまうという潜在的なセキュリティリスクがあるためです。また署名済みアップレットを使わないと、Javaのセキュリティ上の問題によりファイルの読み込みはブロックされるでしょう。
 +
 
 +
例:
 +
<nowiki>http://www.rcsb.org/pdb/explore/jmol.do?structureId=1CRN&bionumber=1&</nowiki><font color=red><nowiki>JMOLJAR=http://chemapps.stolaf.edu/jmol/jsmol/java/JmolAppletSigned0.jar</nowiki></font>
 +
Bobの最新バージョンJmol(現在バージョン12.2、署名済み)を使ってRCSBサイトにある構造を表示します。
 +
[http://www.rcsb.org/pdb/explore/jmol.do?structureId=1CRN&bionumber=1&JMOLJAR=http://chemapps.stolaf.edu/jmol/jsmol/java/JmolAppletSigned0.jar こちら]にアクセスしてみて下さい。
 +
 
 +
以下の指定を追加すれば、同じアップレットを署名付きに変えて表示することができます(Jmol.js 12.2.RC8以降)
 +
?JMOLJAR=SIGNED
 +
(但し、ウェブサイト作成者が署名済みアップレットファイルを配置していなかった場合はアップレットの起動に失敗します。)
 +
 
 +
== WikiへのJmol埋め込み ==
 +
 
 +
Jmolアップレットは[[wikipedia:HTML|HTML]](またはXHTML)で埋め込むことができます(事例が[[Websites Using Jmol/ja|Jmolを使ったウェブサイト]]([[Websites Using Jmol|英語版]])に列挙されています)。但し、これをwikiページに埋め込むには追加で必要となる技術的なことがいくつかあります。詳しくは[[Jmol Processor/ja|Jmolの処理について]]([[Jmol Processor|英語版]])をご覧下さい。
 +
 
 +
 
 +
== データアクセスにおける非署名版と署名版の違い ==
 +
 
 +
[[File:Java_Warning_Signed.png|right|231px]]
 +
'''署名付き'''アップレットはどんなhttpやftpのURLからでも分子構造データを読み込むことができます。
 +
但し、ユーザは署名されたアップレットを信頼するよう求められます(右図参照)。
 +
ただ発行元(jmol.org)は「検証されていない」もので、セキュリティ証明書は「信頼されていない」グループ(jmol.org)によって発行されているため問題があります。
 +
 
 +
こうしているのは信頼された(商用の)証明書で各バージョンのアップレットを署名するのは費用がかかり、手続きが繁雑となるからです。
 +
 
 +
'''非署名版'''アップレットによって分子を表示する際、ユーザは信頼するかどうかを尋ねられることはありません。
 +
しかし(セキュリティ上の理由から)、アップレット自体があるのと同一のhttpドメイン(サーバ)にある分子構造データしか読み込みことはできません。
 +
[http://firstglance.jmol.org/ FirstGlance in Jmol]は特に指定がなければ非署名版を使いますが、「詳細オプション」(Advanced Option)がONになっている時は署名付きを使います。これで両方のアップレットの動作を簡単にみることができます。任意のサーバにあるデータファイルへアクセス方法について詳しくは[http://bioinformatics.org/firstglance/fgij/datameth.htm PDBデータへのアクセス方法]を参照して下さい。
 +
 
 +
'''ローカルディスク'''にあるウェブページを使っているなど、まだアップレットをウェブサーバで動作させて''いない''のであれば、Javaによって更にセキュリティ上の制限が加えられます。分子構造データはアップレットファイル群があるディレクトリと同一階層またはそれ以下の階層にあるフォルダにあるものしか利用できません。詳しくは[[Jmol Applet Deployment Local/ja|Jmolアップレットをローカルで開発する]]([[Jmol Applet Deployment Local|英語版]])を参照して下さい。
 +
 
 +
 
 +
== Jmolウェブページを作成するためのツール ==
 +
===Jmol.php: Jmolを簡単にウェブページへ===
 +
単に<code><script></code>タグや<code><a></code>タグを記すだけでJmolアップレットををウェブページに埋め込むことができます。
 +
Jmolファイルをコンピュータやウェブサーバにインストールする必要はありません。
 +
分子の立体構造ファイルさえ必要ありません。必要なファイルは自動的に適当なウェブサーバからダウンロードされます。
 +
 
 +
この方法を使えば、ソースコード全体を管理することなくどんな環境でも使えるJmolページを簡単に作成することができます。フォーラム、ブログ、wiki、コンテンツ管理システム、e-learning環境などは必要ありません。実は、URLを電子メールで送り、受け取った人はメールに記載されたリンクをクリックするだけでJmolアップレットをみることができるのです。
 +
 
 +
詳しくは[[Jmol_PHP/ja|Jmol PHP]]([[Jmol_PHP|英語版]])をご覧下さい。
 +
 
 +
===プロテオペディアの表示設定編集ツール===
 +
[http://proteopedia.org プロテオペディア]でページを作成するのが、Jmolによる分子画像をカスタマイズしてウェブページに埋め込み、シェアする最も簡単な方法です。
 +
 
 +
プロテオペディアの''分子表示設定編集ツール''を使えば、Jmolコマンド、HTML、JavaScriptについて学ぶことから解放されます。
 +
 
 +
wikiテキストの文法を少し学ぶだけで便利なボタンやヘルプを作成できるのです。
 +
 
 +
一方、もしJmolコマンドをいくらか知っているのであれば、コマンドを使って好きな画像を作ることもできます(Jmolコンソールを使って)。
 +
どんな表示設定でも、Jmol状態スクリプトを使って設定内容を保存することができます。
 +
原子座標ファイルをアップロードしたり、公開されているPDBファイルを利用したりすることもできます。
 +
プロテオペディアでは[[Wikipedia:蛋白質構造データバンク|蛋白質構造データバンク(PDB)]]でファイルの更新が行われたりしてもスクリプトが壊れないよう、利用しているPDBファイルを自動的に保存します。
 +
また他人が編集できないページを作ることもできます。
  
例:
+
===Jmolの''ウェブへの出力''===
* -Xmx512M  最大512MBまでメモリの使用を許可
+
html/xhtmlやJavaScriptのコードを書きたくない、あるいはいくつかある簡単なページを簡単に統合したいというのであれば、
* -Xmx1024M    最大1024MBまでメモリの使用を許可
+
'''Jmolのウェブ出力機能'''(バージョン11.4以降で利用可能)についての説明をご覧下さい。
 +
この機能を使うと、全ての必要なファイルを出力して、ボタンをクリックするだけで表示などを変更することができるJmolアップレットページを作ることができます。
 +
ユーザに見せたい表示様式はJmol上で設定できます。
 +
後はウェブエディタの出力機能を使って、好きなテキストやコマンドを .html ファイルに追加して下さい。
 +
# [http://www.seamonkey-project.org/ SeaMonkey]はシンプルですがよく機能します
 +
# [http://www.kompozer.net/ Kompozer]はより高機能ですがかなりよく機能します
 +
# [http://www.w3.org/Amaya/ Amaya]は最も高機能ですが使いこなすのは難しくなります
  
このパラメータの設定場所は以下の通りです:
+
出力機能の利用方法については、Jmolアプリケーションのウェブダイアログに出力して参照できます。
 +
詳しい説明や過去のパッケージについては[http://www.uwosh.edu/faculty_staff/gutow/Jmol_Web_Page_Maker/Jmol_Web_Page_Maker.shtml Jmolウェブページメーカー]をご覧下さい。
 +
<!--[[User:Gutow|Gutow]] 21:48, 25 July 2008 (CEST)-->
  
:'''Windowsの場合''':
+
== アップレットからファイルを保存する ==
 +
これは明記されていないことなのですが、実はアップレットで表示されている分子のデータは(例え'''署名されていないアップレット'''であっても)ローカルディスクに保存することができるのです。但し、インラインで読み込まれた構造に限ります。その方法は以下の通りです。
  
::コントロールパネル > Javaアイコン([[Solving_Java_Problems#Java_Control_Panel|Javaコントロールパネル]]を開く)>「Java」タブ > 「アプレット ランタイム設定」>「ボタンの表示」>「JRE」行(最新バージョンでは複数行あります)の「パラメータ」テキストボックスをクリックし、「-Xmx###M」と入力
+
# アップレットメニューを開く(右クリック、Ctrl+クリック、または右下の「Jmol」ロゴをクリック)
 +
# 一番下の項目(Jmolについて)をクリック
 +
# 表示される下位メニューの一番上に、最初に読み込まれた構造の名前が表示されています。何か文字列が書かれていれば構造がインラインで読み込まれたことを、404で始まっていればデータが見つからなかったことを示します。もし文字列がファイル名を示している場合は、次のステップに進むことができます。複数のファイルが読み込まれていた場合、各ファイルの名前が1行に1つずつ表示されます。開きたいファイルあるいは保存したいファイルの名前をクリックして下さい。次の層のメニューオプションが開きます。
 +
# 一番下にある項目(ファイル名+「を表示」)をクリック
 +
# ファイルが関連づけられたプログラム(ヘルパーアプリケーション)で開かれるか、あるいは「ファイルを開く/保存する」ダイアログが表示されます。後者の場合は、保存先を指定して下さい。どのような挙動をするかはブラウザの設定に依存します。
  
:'''Macintoshの場合''':
+
:''旧バージョンJmolの場合'':
 +
# アップレットメニューを開く(右クリック、Ctrl+クリック、または右下の「Jmol」ロゴをクリック)
 +
# 一番上の項目(分子名)をクリック
 +
# 表示される下位メニューの一番上にある項目(モデル名)をクリック
 +
# ファイルが関連づけられたプログラム(ヘルパーアプリケーション)で開かれるか、あるいは「ファイルを開く/保存する」ダイアログが表示されます。後者の場合は、保存先を指定して下さい。どのような挙動をするかはブラウザの設定に依存します。
  
::/Applications/Utilities/Java/J2SE 5.0/Java Preferences を開き、「基本」タブの画面中央「Javaアプレット実行時のパラメータ」欄に「-Xmx###M」と入力する。
+
:''警告'': 少なくともWindows環境下において、最近のブラウザはこの動作をポップアップウインドウを開く動作として検知し、ポップアップがブロックされることにより「ファイルを開く/保存する」ダイアログが表示されない場合があります。表示メッセージやブラウザの設定に注意し、このページではポップアップを許可するようにして下さい(通常この類のメッセージは、ページの上端に黄色い帯、ツールバー内の警告、ブラウザ画面下端にあるステータス行内のヒントで表示されます)。
::または [[Solving_Java_Problems#Java_Control_Panel|Javaコントロールパネル]] を見て下さい。
 
  
これはローカルの設定なので、設定したコンピュータでしか有効になりません。あなたのウェブページを訪問した人が同じJavaメモリ設定を行っているとは限らないので、この設定変更の利用には注意して下さい。
+
:''Chimeユーザへの注意'': MDL Chimeをインストールしている場合、分子構造はChimeを使ってブラウザウインドウ内で開かれます。Chimeのメニュー(File > Save molecule as)を使えば構造ファイルをディスクに保存することができます。
  
技術的詳細事項:
+
'''署名済みアップレット'''を使ったページでは、より直感的で全機能を備えた<code>File</code>サブメニューが利用できます。このメニューはポップアップメニューの下の方にあります。
* -Xmx はJavaVMに利用を許可する最大メモリ量(maximum memory heap size)を設定します。
 
* -Xms はJavaVMに利用を許可する最小メモリ量(minimum memory heap size)を設定します。
 
  
[[Jmol_Application#Giving_Jmol_more_memory_to_work_with|アプリケーションの実行]]もご覧下さい。
+
全構造を保存できるだけでなく、構造の'''一部分だけ'''を取り出してMOLフォーマットで保存することもできます。これは以前ほど直感的ではなくなっています。
 +
詳細は「対話的スクリプトについて」に記しています([{{Website}} Jmolホームページ]も参照して下さい)。
  
===  Jmolアップレットを強制的にある特定の言語で開く ===
+
また'''分子の表示設定'''(表示様式、配色、表示範囲、配置など)も保存できます。「Jmolスクリプトについて」の[http://www.stolaf.edu/academics/chemapps/jmol/docs/?ver=11.0#save <code>save state</code>][http://www.stolaf.edu/academics/chemapps/jmol/docs/?ver=11.0#write <code>write state</code>]を参照下さい。これはChimeやRasmolでできることと似ていますが、Javaのセキュリティ制約によりファイルに保存する機能は非署名版アップレットでは利用できません。但し、それに代わる方法として、コンソールでデータを表示し、その内容を[[Troubleshooting/Applet/ja#Extracting_information_from_the_applet|テキストエディタにコピー]]([[Troubleshooting/Applet#Extracting_information_from_the_applet|英語版]])して保存するやり方があります。
Jmolアップレットのユーザインタフェース(ポップアップメニュー)では[[Internationalisation/Current_Status|いくつかの言語]]が利用できます(技術的には局地化 localization と言います)。
 
Jmolアップレットは、デフォルトではあなたが使っているOSのユーザインタフェースで使われている言語で開かれます([http://java.sun.com/j2se/corejava/intl/reference/faqs/index.html#set-default-locale ref.])。しかしもしそれを変更するのであれば、以下の方法を用いて下さい。
 
  
# Jmol 11.1.30 より、アップレットの言語はポップアップメニューの「Language」からいつでも変更できるようになりました。
+
==クラウドストレージAWS S3のバケットにJmolサイトを構築する==
# 以下のスクリプト言語で言語を指定することもできます。<code> language = "de" </code>("language" キーワードに2文字の言語コードを指定します。現在利用できる言語コードはca, cs, de, en, es, et, fr, nl, pt, trです。)
 
# ''これは11.1.30より古いバージョンでのみ必要となる古い方法です。'' 表示言語をある特定の言語にしたいなら以下の操作等を行います。
 
<blockquote>
 
  <blockquote>
 
'''Windowsの場合''':
 
Windowsのコントロールパネル > Javaアイコン(Javaコントロールパネルが開く) > 「Java」タブ > アプレットランタイム設定 > ボタン表示 >
 
「JRE」グループにある「パラメータ」の下にあるテキストボックスをクリックし、以下の内容を入力します。
 
<pre>
 
  java -Duser.language=es    # forces Spanish (Español)
 
  java -Duser.language=de    # forces German (Deutsch)
 
  java -Duser.language=en    # forces English
 
  etc.
 
</pre>
 
  </blockquote>
 
  <blockquote>
 
'''Macintoshの場合''':
 
「/Applications/Utilities/Java/J2SE 5.0/Java Preferences」にあるJavaコントロールパネルを開き、上記Windowsの場合と同様のパラメータを入力して下さい。
 
  </blockquote>
 
</blockquote>
 
  
[[Jmol_Application#Forcing_Jmol_to_open_in_a_certain_language|アプリケーションの実行方法]]もご覧下さい。
+
2013年10月: この節はAWS S3のバケット(ファイルの入れ物)に簡単なJmolデモサイトを設定する方法について説明します。
 +
ちなみに、前節までに記したJmolAppletxxx、html、構造の各ファイルが機能するための配置方法についても再確認のため記しています。
 +
ここではJava版のJmolについてのみ記しており、JSmolについての内容は含まれていません。
  
== WikiでのJmol ==
+
AWS S3(Amazon Web Services, Simple Storage Service、Amazonのストレージサービス)はアップレットに埋め込んだ簡単なJmolデモサイトを構築するのにうってつけです。
  
アップレットは [[wikipedia:HTML|HTML]](またはXHTML)ページに埋め込むことができます(例を [[Websites Using Jmol]] に挙げてある他、[[Jmol Processor]] にもいくつかの追加技術が必要な事例が挙げてあります。)
+
S3は信頼性のある、安価なクラウドストレージで、ウェブアクセスサービスを基本としています。
 +
小さなサイトであれば費用は取るに足らないほどです: http://aws.amazon.com/s3/pricing/
 +
またAWS無料利用枠を使って12ヶ月間無料でストレージにアクセスできる便利な制度もあります。
 +
このサービスを使えば組織で所有しているコンピュータでウェブサービスを利用する際に生じる様々な問題点を回避できます。
  
== 未署名と署名済み、データアクセス ==
+
S3バケットの利用例を以下に挙げます。
  
'''署名された'''アップレットの場合、任意のhttpまたはftpのURLから分子モデルを読み込むことができます。但し、ユーザは署名されたアップレットを信頼するよう尋ねられます。これは問題となる可能性があります。なぜなら製造元(jmol.org)は「検証できず」、セキュリティ証明書は「信頼されていない」(jmol.org)グループのものであると表示されてしまうからです。これはバージョンアップの度に信頼された(商業的な)認証局でアップレットを署名してもらうのは費用がかかり、面倒だからです。
+
学術的論文の補足情報を提供する、プロテオミクスデータアーカイブ:
 +
http://mouse-brain-ptmome.s3.amazonaws.com/list.html
  
'''署名されていない'''アップレットは閲覧するユーザに対してそれを信用するかどうかを問い合わせることなく分子を表示します。しかし、セキュリティ上の理由からアップレット自身をダウンロードしたのと同じhttpドメイン(サーバ)からしか分子モデルを読み込むことはできません。[http://firstglance.jmol.org/ FirstGlance in Jmol] はデフォルトでは署名されていないアップレットを使います。そのため、簡単に両方が動くのを見ることができます。任意のサーバからデータファイルにアクセスする方法について詳しくは[http://bioinformatics.org/firstglance/fgij/datameth.htm PDBデータファイルのアクセス方法]に記されています。
+
Jmolデモ: http://ptmjmol.s3.amazonaws.com/section1/trace.html
  
もしあなたがいずれのサーバ上でもアップレットを''動かしていない''、つまりウェブページをローカルディスク上に置いて利用しているのであれば、更にセキュリティ上の制約がJavaによって課せられます。分子モデルはアップレットがあるのと同じかその配下のフォルダ(ディレクトリ)にあるものしか利用できません。この件に関して、[[Jmol Applet Deployment Local|Jmolアップレットをローカルに置く]]も参照して下さい。
+
画像ギャラリー: http://ptmgallery.s3.amazonaws.com/list.html
  
== Jmolウェブページに署名するツール ==
+
Amazonで本を買うためのアカウントを既にお持ちかも知れません。
もしhtml/xhtmlやJavascriptのコードを書きたくないか、あるいは単にJmolを組み込んだ
+
もしまだアカウントをお持ちでないなら、https://www.amazon.com で案内に従いアカウントを作成して下さい(訳注:Amazon日本サイト https://www.amazon.co.jp とは別途アカウントが必要です)。
ウェブページを素早く作りたいなら、Jmolアプリケーションの「export to web function」を見て下さい。
+
次に http://aws.amazon.com/console/ にアクセスして「サインアップ」からログインします。
これによって、多くの動作を伴うJmolページや、ボタンをクリックすることにより表示を変更できるJmolページを作るのに必要なファイル全てをエクスポートすることができます。
+
画面右上「アカウント/コンソール」-「AWSマネージメントコンソール」をクリックしてコンソールを開き、「Storage & Contact Delivery」の「S3」をクリックします。
ウェブページ閲覧者に見せたい分子の視点をJmolに設定して下さい。
 
そして、任意のウェブエディタでエクスポート機能を使って .html ファイルに希望のテキスト、コマンドを追加して下さい。オープンソースのアプリケーションで推奨するものは以下の通りです。
 
* [http://www.seamonkey-project.org/ SeaMonkey] ... もっとも簡単なアプリケーションですが充分使えるものです。
 
* [http://www.kompozer.net/ Kompozer] ... SeaMonkeyより高機能で、よりよく機能します。
 
* [http://www.w3.org/Amaya/ Amaya] ... これはこの中ではもっとも高機能ですが、使い方は難しいです。
 
  
エクスポート機能の使い方に関する説明がJmolアプリケーションの「export to web dialog」にあります。より詳しい説明や過去のパッケージは [http://www.uwosh.edu/faculty_staff/gutow/Jmol_Web_Page_Maker/Jmol_Web_Page_Maker.shtml Jmolウェブページメーカー]に掲載されています--[[User:Gutow|Gutow]] 21:48, 25 July 2008 (CEST)
+
バケット(データの入れ物)を作成します。バケット名は全てのAWSデータセンター内で他と重複しないものにする必要があります。
 +
「test」「mybucket」のような名前は既に使われていて新たに使うことはできないでしょう。
 +
バケットには http://bucketname.s3.amazonaws.com のベースアドレスからアクセスできます。
 +
http://s3.amazonaws.com/bucketname/ からもアクセス可能です。
  
== アップレットからファイルを保存する ==
+
S3コンソールを使うと次のような操作を行うことができます。
これは明記されていませんが、アップレットで表示している分子データをローカルディスクに保存することができます。その方法は以下の通りです。
+
バケット作成、バケット内でのフォルダ・サブフォルダの作成、ファイルのアップロード・ダウンロード、ファイルのアクセス権や種類(Mime type)の設定、その他一般的なファイルシステムの管理(ファイル名の変更、ファイルの削除・切り取り・複製・貼り付けなど)。
# アップレットのメニューを開く(右クリック、Ctrl+クリック、または右下にある「Jmol」ロゴをクリックする)。
+
また扱うファイルの数が多かったり、類似の操作を繰り返し行うような場合に、より効率的に操作を行えるようにするコマンドラインツールや画面ベースでのアプリケーション(下記参照)を利用することもできます。
# 一番上のメニュー(分子名)をクリックする。
 
# 現れたサブメニューの一番下にあるファイル名をクリックする。
 
# ブラウザの設定によりますが、指定されているアプリケーション(ヘルパーアプリケーション)でファイルが開かれるか、あるいは「ファイルを開くまたは保存する」ダイアログが表示され、「保存」を選んでローカルディスク上の保存場所を指定します。
 
  
:''警告'': 少なくともWindows環境において、最近のブラウザはこの操作をウインドウをポップアップする動作として検知してしまうかもしれません。その場合、ポップアップブロッカーが「ファイルを開くまたは保存する」ダイアログが出るのを邪魔してしまうでしょう。ブラウザが出すメッセージとオプション設定に注意して、ページのポップアップを許可するようにして下さい(そのようなメッセージは、ページ上部に現れる黄色いバー、ツールバー中の警告、ブラウザウインドウ最下部のステータスバーのヒントに見られるでしょう)。
+
バケット内で構造データファイルをJmolアップレットで扱えるようにするための配置方法は以下の通りです。
  
:''Chimeユーザへの注意'': MDL Chimeをインストールしている場合、分子はChimeを使ってブラウザウインドウ内で開かれるでしょう。この場合、Chimeのメニュー(File > Save molecule) でファイルをローカルディスクに保存することができます。
+
bucketname
 +
  Jmol.js
 +
  JmolApplet.js
 +
  JmolApplet.jar
 +
  JmolApplet0.jar
 +
  JmolApplet0_Console/Minimize/Popup/ReadersCifPdb/ReadersMolXyz/ReadersMore/ReadersQuantum/ReadersSimple.jar
 +
  JmolApplet0_ReadersXml/ReadersXtal/ShapeBio/ShapeSpecial/ShapeSurface/Smiles/Spectrum/Symmetry.jar
 +
  section1
 +
    mydemo.html
 +
  models
 +
    1GFL.pdb
 +
    4E50.pdb
 +
   
 +
キーとなるスクリプトの設定は以下の通りです。
  
現在、よりユーザにとって使いやすい方法、あるいはJmolアップレットからファイルを保存する方法が開発者によって検討されています。
+
<html>
 +
  ... 
 +
  <script>
 +
    jmolInitialize("..", window.location.protocol=="file:"); 
 +
    ...
 +
    jmolApplet(600, "load ../models/1GFL.pdb");
 +
    ...
 +
 +
バケット内において、全てファイルは通常だれでもアクセスできるようになっています。ファイルタイプはHTMLファイルの場合 text/html、画像ファイルの場合は image/png などとなっています。もしアップロードしたファイルが自動的にこのような設定にならなかった場合、プロパティ - Permissions/Metadata で修正できます。新たなバージョンのファイルをアップロードし直すとこれらの設定は簡単に失われてしまうことに注意して下さい。
  
Jmolバージョン11では、分子の一部分を抽出してMOL形式で保存することができます。これは前述の方法ほど直接的な方法ではありませんが、「対話的なスクリプトに関する文書」にそのことが記載されています( [http://jmol.org/ Jmol ホームページ]も参照して下さい。)
+
ソフトウェアバージョンは以下の通りです:
 +
  Jmol 13.0.18(S3バケットに上記 .js、.jar ファイルを配置)
 +
  確認したブラウザ: Google Chrome 30.0, Firefox 24.0, Safari 5.1, Opera 12.16 
 +
  開発の大半はMac OS X 10.6.8, java 1.6.0_51環境で、テストはMac OS 10.8.5、Windows 7環境で行いました。
  
分子状態(3次元画像の表示方式、配色、透過性、向きなど)を保存する機能は現在開発中ですが、一部についてはJmol 11.0で実装されています。これについてはJmolスクリプトに関する文書の[http://www.stolaf.edu/academics/chemapps/jmol/docs/?ver=11.0#save <code>save state</code>] と [http://www.stolaf.edu/academics/chemapps/jmol/docs/?ver=11.0#write <code>write state</code>]を参照して下さい。これによってChimeやRasmolと機能的に近いことができますが、Javaのセキュリティ制限のためファイルへの保存はJmolアップレットの場合には利用できません。
+
S3バケット管理をより簡単にするためのフリーツールを以下に挙げます:
 +
http://aws.amazon.com/developertools/739    ... コマンドラインツール
 +
http://www.timkay.com/aws/                 ... 前項の別URL
 +
http://s3browser.com/                       ... Windows用のS3バケット管理を行うGUIツール

Latest revision as of 20:23, 25 March 2019


Geographylogo.png

Reference: English – Other: 日本語 ·


Running Jmol

Jmol オブジェクト

Jmolアップレット

Javaアップレット版のJmolを使うと、ウェブページにJmolを埋め込むことができます(Javaプラグインがインストールされたブラウザで見ることができます)。スタンドアロン版と同様に、スクリプトを使うことができます。例をいくつかデモページ http://www.jmol.org/demo/ に挙げてあるので参照して下さい。ウェブブラウザでHTMLソースを見るには、Firefoxの場合 表示ページのソース をクリックして下さい。

Jmol HTML5オブジェクト(JSmol)

バージョン13.1から、JSmolと呼んでいる非Java版Jmolを使ってJmolをウェブページに埋め込むことができるようになりました。 これによりJavaScriptだけを用いるHTML5オブジェクトが使ってJmolアップレットと同等の機能が実現できます。 詳しくはJmol JavaScriptオブジェクト英語版)を参照して下さい。

Jmolオブジェクトのインストール

Jmolによる分子画像をウェブページに組み込みたいだけであれば、テストページ作りから始めるよりも簡単な方法があります。 Jmolウェブページを作るためのツールを参照して下さい。 Jmolを埋め込んだウェブページを作成する方法を知りたいのであれば、右記「Jmolをインストールする」を参照して下さい。

Installing Jmol

Jmolパッケージ(.zip版、tar.gz版どちらでも構いません)をダウンロードし、解凍・展開して、必要なファイルだけを使って下さい。

どのファイルが必要なのかについては、以下をご覧下さい。

ローカル環境(ハードディスクやCD)のウェブページでJmolアップレットを使う場合、あらかじめ注意しておくべき点がいくつかあります。Jmolアップレットをローカルで開発する英語版)を参照して下さい。

場合によっては別のファイルを使う必要があります。以下に記している署名付きアプレットについてをお読み下さい。

アップレットが起動しない場合、Javaに関する問題の解決策英語版)を参照下さい。

ウェブページを配布する場合、以下に記す著作権、許諾条件、諸情報を記したファイルを含めておく必要があります。

  • File icon.gifCOPYRIGHT.txt
  • File icon.gifLICENSE.txt
  • File icon.gifREADME.txt

ウェブページにJmolオブジェクトを埋め込む

JavaScriptをベースとした2つの方法を使うと簡単にJmolアップレット・オブジェクトをウェブページに埋め込み、管理することができます。


Jmol JavaScript オブジェクト(Jmol-JSO)

Jmol-JSO(Jmolバージョン13で新たに導入されました)を使うと、きれいで効率的な方法でJavaScriptからJmolアップレットを操作することができます。 更にJavaやアップレットの利用に制約があるiPad、iPhone、Androidモバイル端末などでも利用できるほか、Jmol Javaアップレットが使えない環境であってもRCSB PDBデータベースアメリカ国立がん研究所のCACTVSサーバPubChemなどの公開データベースへ簡単にアクセスできます。

これにはJavaに代わる基本的で高機能なスクリプト機能が備わっています。更に、Jmol-JSOを使うことによりJSpecViewアップレットJMEアップレットによる2次元-3次元モデル構築・相互変換と同期する機能も付加することができます。

詳しくは[Jmol JavaScript Object/ja|Jmol JavaScriptオブジェクト]([Jmol JavaScript Object|英語版])を参照して下さい。

Jmol.jsライブラリ

Jmol.jsはJmolバージョン12用のライブラリ(使おうと思えばバージョン13でも使うことはできます)で、ボタン、チェックボックス、リンク、メニューのような対話操作機能を含むウェブページを素早く構築できるようにする一連のスクリプトコマンドを提供します。

Jmol.jsに実装された全ての機能はJmol-JSOでも実装されています。 これら機能の概要についてはJmol.jsオンラインドキュメント、あるいは最新の情報が掲載されている Jmol.js のソースファイルを参照して下さい。

注: File icon.gifJmol.jsはJmolバージョン13より段階的に廃止され、新たなオブジェクト指向JavaScriptとFile icon.gif.jsファイルを用いた方法に移行します(詳細は次節)。またJmolバージョン13.2以降のダウンロードコンテンツにはJmol.jsに関連するファイル群は含まれません。引き続き利用したいのであれば、別途Jmolレポジトリから入手して下さい。特に2014年1月から、Javaの新たなセキュリティポリシーによって古いバージョンのFile icon.gifJmol.jsは機能しなくなります。もしウェブサイトをJmol-JSOを使ったもの英語版)に移行できないか、あるいは移行期間用のアダプタJmol2.jsを使うのであれば、新しいJmol.jsをダウンロードして既存のJmol.jsファイルを置き換える必要があるでしょう。

JmolアップレットJARファイル

Jmol-JSOもJmol.jsも共にJavaScriptライブラリを使っていますが、Jmolをアップレットとして実装するには4種類の方法があります。

  • 単一の非署名アップレットを使う方法 File icon.gifJmolApplet.jarだけを使ってウェブサイトを構築するというやり方です。Jmol.jsを使う場合は、アップレットは同一サイト内のファイルにのみアクセスします。Jmol-JSOを使う場合は、同一サイト内のファイルに加え公開データベースのファイルにもアクセスします。
  • 非署名アップレットモジュール群を使う方法 File icon.gifJmolApplet0.jarとそれに関連するファイル(全部で54個のFile icon.gifjarファイルがあります)をウェブサイトに使います。ファイル数は多くなりますが、最初にダウンロードされるのはJmolの必要な部分だけであるという利点があります。ダウンロードされていない部分は必要に応じ追加ダウンロードされます。この方法だとアップレットの起動がより速くなります。
  • 単一の署名済みアップレットを使う方法 File icon.gifJmolAppletSigned.jarは署名済みJmolアップレットで使う全ての機能を実装した単一のファイルで、ファイルサイズは2.5MB以上ある大きなものです。この署名済みアップレットを使うとより多くの機能が使えるようになり、異なるドメインへのファイルにアクセスしたり、ユーザのローカルハードディスクにファイルを転送したりといったことができるようになります。
  • 署名済みアップレットモジュール群を使う方法

File icon.gifJmolAppletSigned0.jarおよびこれに関連するファイル(JmolApplet0.jarなど)を使って、必要なモジュールだけをユーザのブラウザに転送することができます。署名済みアップレットを使う場合、この方法を推奨します。

Jmolアップレットにより多くのメモリを割り当てて動作させる方法

注:これはJmol.js(jmolSetMemoryMb(nMb))でもJmol-JSO(Info.memoryLimit = nMb)でも行うことができます。

Jmolが利用できるメモリ量はJavaによって決められています。アップレットのポップアップメニューを開き、一番下にある「Jmolについて」から現在のメモリ割り当て量を確認することができます。

以下のパラメータにより割り当てメモリ量を増減することができます。

-Xmx###M

###にはメガバイト単位の数値を指定します(この例の場合、後ろに「M」を付けているので)。但し、割り当てることのできるメモリ量はシステムに実装されている物理メモリ量によって制限されます。例えば、システムに512MBのRAMがある場合、Javaが割り当てることのできるメモリ量は最大256MBです。

例:

  • -Xmx512M 最大512MBのメモリが利用可能
  • -Xmx1024M 最大1024MBのメモリが利用可能

このパラメータの設定位置はシステムによって異なります:

Windows

  • コントロールパネル > Javaアイコン(Javaコントロールパネル英語版)が開く) > 「Java」タブ > 「アプレット ラインタイム設定」 > 「表示」ボタン > 「JRE」行(複数行ある場合はバージョンが最も新しいもの)をクリックし、「パラメータ」のテキストボックスに「-Xmx###M」と入力する。

Macintosh

  • OS 10.5 (Leopard): /アプリケーション/ユーティリティ にある JavaPreferences.app をダブルクリック。「全般」タブでリストの最初にあるバージョンのJavaを選択し、有効になった「オプション」ボタンをクリック。「アプレット ランタイムパラメータ」が開く。ここにパラメータ「-Xmx###M」を入力。
  • OS 10.4 (Tiger): /アプリケーション/ユーティリティ/Java/J2SE 5.0/Java Preferences を開いて、「-Xmx###M」を入力する箇所を探して下さい。

Javaコントロールパネル英語版)も参照して下さい。

これはローカルマシンの設定について記していて、その設定を行ったコンピュータにしか変更は反映されません。ウェブページを閲覧するユーザが同じJavaメモリ設定を行っているとは限りません。メモリ割り当て量を変更する時はこの点に注意して下さい。

技術的詳細情報:

  • -Xmx は利用可能な最大メモリサイズを設定します。
  • -Xms は利用可能な最小メモリサイズを設定します。

アプリケーションのメモリ取り扱いについて英語版)もご覧下さい。


Jmolアップレットをある特定の言語で表示させる

Jmolアップレットではユーザインタフェース(ポップアップメニュー)に利用できる言語を複数備えています(技術的にはこのことを現地語化 localization と呼んでいます)。 初期状態では、OSで使用されている言語(参考)がアップレットのインタフェースに適用されます。これを変更する方法は以下の通りです。

  1. Jmol 11.1.30以降、アップレットの使用言語はいつでも変更できるようになりました。言語はポップアップメニューの下方にある「言語」から変更できます。
  2. 表示言語はスクリプト言語を使って変更することもできます。例: language = "de" (「language」というキーワードと言語を示す2文字コードで指定します。言語コードはca, cs, de, en, es, et, fr, ja, nl, pt, trなどが利用できます)。


異なるアップレットのバージョンを試す

(これは上級者向け機能です)

任意のウェブページ(自身が管理しているページでなくても構いません)に埋め込まれたJmolアップレットを強制的にある特定のバージョンで動作させることができます。 その方法は以下の通りです。

利用しようとしているJmolのjarファイル(File icon.gifJmolApplet0.jarまたはFile icon.gifJmolAppletSigned0.jar)を示すURLの末尾に以下の文字列を追記します。

?JMOLJAR=

もし既にURL中に?が存在する場合は、代わりに&JMOLJAR=を追記して下さい。

いくつか警告が表示され、許可するよう求められるでしょう。これは全く関係のないサーバにある別のアップレットと置き換えられてしまうという潜在的なセキュリティリスクがあるためです。また署名済みアップレットを使わないと、Javaのセキュリティ上の問題によりファイルの読み込みはブロックされるでしょう。

例:

http://www.rcsb.org/pdb/explore/jmol.do?structureId=1CRN&bionumber=1&JMOLJAR=http://chemapps.stolaf.edu/jmol/jsmol/java/JmolAppletSigned0.jar

Bobの最新バージョンJmol(現在バージョン12.2、署名済み)を使ってRCSBサイトにある構造を表示します。 こちらにアクセスしてみて下さい。

以下の指定を追加すれば、同じアップレットを署名付きに変えて表示することができます(Jmol.js 12.2.RC8以降)

?JMOLJAR=SIGNED

(但し、ウェブサイト作成者が署名済みアップレットファイルを配置していなかった場合はアップレットの起動に失敗します。)

WikiへのJmol埋め込み

JmolアップレットはHTML(またはXHTML)で埋め込むことができます(事例がJmolを使ったウェブサイト英語版)に列挙されています)。但し、これをwikiページに埋め込むには追加で必要となる技術的なことがいくつかあります。詳しくはJmolの処理について英語版)をご覧下さい。


データアクセスにおける非署名版と署名版の違い

Java Warning Signed.png

署名付きアップレットはどんなhttpやftpのURLからでも分子構造データを読み込むことができます。 但し、ユーザは署名されたアップレットを信頼するよう求められます(右図参照)。 ただ発行元(jmol.org)は「検証されていない」もので、セキュリティ証明書は「信頼されていない」グループ(jmol.org)によって発行されているため問題があります。

こうしているのは信頼された(商用の)証明書で各バージョンのアップレットを署名するのは費用がかかり、手続きが繁雑となるからです。

非署名版アップレットによって分子を表示する際、ユーザは信頼するかどうかを尋ねられることはありません。 しかし(セキュリティ上の理由から)、アップレット自体があるのと同一のhttpドメイン(サーバ)にある分子構造データしか読み込みことはできません。 FirstGlance in Jmolは特に指定がなければ非署名版を使いますが、「詳細オプション」(Advanced Option)がONになっている時は署名付きを使います。これで両方のアップレットの動作を簡単にみることができます。任意のサーバにあるデータファイルへアクセス方法について詳しくはPDBデータへのアクセス方法を参照して下さい。

ローカルディスクにあるウェブページを使っているなど、まだアップレットをウェブサーバで動作させていないのであれば、Javaによって更にセキュリティ上の制限が加えられます。分子構造データはアップレットファイル群があるディレクトリと同一階層またはそれ以下の階層にあるフォルダにあるものしか利用できません。詳しくはJmolアップレットをローカルで開発する英語版)を参照して下さい。


Jmolウェブページを作成するためのツール

Jmol.php: Jmolを簡単にウェブページへ

単に<script>タグや<a>タグを記すだけでJmolアップレットををウェブページに埋め込むことができます。 Jmolファイルをコンピュータやウェブサーバにインストールする必要はありません。 分子の立体構造ファイルさえ必要ありません。必要なファイルは自動的に適当なウェブサーバからダウンロードされます。

この方法を使えば、ソースコード全体を管理することなくどんな環境でも使えるJmolページを簡単に作成することができます。フォーラム、ブログ、wiki、コンテンツ管理システム、e-learning環境などは必要ありません。実は、URLを電子メールで送り、受け取った人はメールに記載されたリンクをクリックするだけでJmolアップレットをみることができるのです。

詳しくはJmol PHP英語版)をご覧下さい。

プロテオペディアの表示設定編集ツール

プロテオペディアでページを作成するのが、Jmolによる分子画像をカスタマイズしてウェブページに埋め込み、シェアする最も簡単な方法です。

プロテオペディアの分子表示設定編集ツールを使えば、Jmolコマンド、HTML、JavaScriptについて学ぶことから解放されます。

wikiテキストの文法を少し学ぶだけで便利なボタンやヘルプを作成できるのです。

一方、もしJmolコマンドをいくらか知っているのであれば、コマンドを使って好きな画像を作ることもできます(Jmolコンソールを使って)。 どんな表示設定でも、Jmol状態スクリプトを使って設定内容を保存することができます。 原子座標ファイルをアップロードしたり、公開されているPDBファイルを利用したりすることもできます。 プロテオペディアでは蛋白質構造データバンク(PDB)でファイルの更新が行われたりしてもスクリプトが壊れないよう、利用しているPDBファイルを自動的に保存します。 また他人が編集できないページを作ることもできます。

Jmolのウェブへの出力

html/xhtmlやJavaScriptのコードを書きたくない、あるいはいくつかある簡単なページを簡単に統合したいというのであれば、 Jmolのウェブ出力機能(バージョン11.4以降で利用可能)についての説明をご覧下さい。 この機能を使うと、全ての必要なファイルを出力して、ボタンをクリックするだけで表示などを変更することができるJmolアップレットページを作ることができます。 ユーザに見せたい表示様式はJmol上で設定できます。 後はウェブエディタの出力機能を使って、好きなテキストやコマンドを .html ファイルに追加して下さい。

  1. SeaMonkeyはシンプルですがよく機能します
  2. Kompozerはより高機能ですがかなりよく機能します
  3. Amayaは最も高機能ですが使いこなすのは難しくなります

出力機能の利用方法については、Jmolアプリケーションのウェブダイアログに出力して参照できます。 詳しい説明や過去のパッケージについてはJmolウェブページメーカーをご覧下さい。

アップレットからファイルを保存する

これは明記されていないことなのですが、実はアップレットで表示されている分子のデータは(例え署名されていないアップレットであっても)ローカルディスクに保存することができるのです。但し、インラインで読み込まれた構造に限ります。その方法は以下の通りです。

  1. アップレットメニューを開く(右クリック、Ctrl+クリック、または右下の「Jmol」ロゴをクリック)
  2. 一番下の項目(Jmolについて)をクリック
  3. 表示される下位メニューの一番上に、最初に読み込まれた構造の名前が表示されています。何か文字列が書かれていれば構造がインラインで読み込まれたことを、404で始まっていればデータが見つからなかったことを示します。もし文字列がファイル名を示している場合は、次のステップに進むことができます。複数のファイルが読み込まれていた場合、各ファイルの名前が1行に1つずつ表示されます。開きたいファイルあるいは保存したいファイルの名前をクリックして下さい。次の層のメニューオプションが開きます。
  4. 一番下にある項目(ファイル名+「を表示」)をクリック
  5. ファイルが関連づけられたプログラム(ヘルパーアプリケーション)で開かれるか、あるいは「ファイルを開く/保存する」ダイアログが表示されます。後者の場合は、保存先を指定して下さい。どのような挙動をするかはブラウザの設定に依存します。
旧バージョンJmolの場合:
  1. アップレットメニューを開く(右クリック、Ctrl+クリック、または右下の「Jmol」ロゴをクリック)
  2. 一番上の項目(分子名)をクリック
  3. 表示される下位メニューの一番上にある項目(モデル名)をクリック
  4. ファイルが関連づけられたプログラム(ヘルパーアプリケーション)で開かれるか、あるいは「ファイルを開く/保存する」ダイアログが表示されます。後者の場合は、保存先を指定して下さい。どのような挙動をするかはブラウザの設定に依存します。
警告: 少なくともWindows環境下において、最近のブラウザはこの動作をポップアップウインドウを開く動作として検知し、ポップアップがブロックされることにより「ファイルを開く/保存する」ダイアログが表示されない場合があります。表示メッセージやブラウザの設定に注意し、このページではポップアップを許可するようにして下さい(通常この類のメッセージは、ページの上端に黄色い帯、ツールバー内の警告、ブラウザ画面下端にあるステータス行内のヒントで表示されます)。
Chimeユーザへの注意: MDL Chimeをインストールしている場合、分子構造はChimeを使ってブラウザウインドウ内で開かれます。Chimeのメニュー(File > Save molecule as)を使えば構造ファイルをディスクに保存することができます。

署名済みアップレットを使ったページでは、より直感的で全機能を備えたFileサブメニューが利用できます。このメニューはポップアップメニューの下の方にあります。

全構造を保存できるだけでなく、構造の一部分だけを取り出してMOLフォーマットで保存することもできます。これは以前ほど直感的ではなくなっています。 詳細は「対話的スクリプトについて」に記しています(Jmolホームページも参照して下さい)。

また分子の表示設定(表示様式、配色、表示範囲、配置など)も保存できます。「Jmolスクリプトについて」のsave statewrite stateを参照下さい。これはChimeやRasmolでできることと似ていますが、Javaのセキュリティ制約によりファイルに保存する機能は非署名版アップレットでは利用できません。但し、それに代わる方法として、コンソールでデータを表示し、その内容をテキストエディタにコピー英語版)して保存するやり方があります。

クラウドストレージAWS S3のバケットにJmolサイトを構築する

2013年10月: この節はAWS S3のバケット(ファイルの入れ物)に簡単なJmolデモサイトを設定する方法について説明します。 ちなみに、前節までに記したJmolAppletxxx、html、構造の各ファイルが機能するための配置方法についても再確認のため記しています。 ここではJava版のJmolについてのみ記しており、JSmolについての内容は含まれていません。

AWS S3(Amazon Web Services, Simple Storage Service、Amazonのストレージサービス)はアップレットに埋め込んだ簡単なJmolデモサイトを構築するのにうってつけです。

S3は信頼性のある、安価なクラウドストレージで、ウェブアクセスサービスを基本としています。 小さなサイトであれば費用は取るに足らないほどです: http://aws.amazon.com/s3/pricing/ またAWS無料利用枠を使って12ヶ月間無料でストレージにアクセスできる便利な制度もあります。 このサービスを使えば組織で所有しているコンピュータでウェブサービスを利用する際に生じる様々な問題点を回避できます。

S3バケットの利用例を以下に挙げます。

学術的論文の補足情報を提供する、プロテオミクスデータアーカイブ: http://mouse-brain-ptmome.s3.amazonaws.com/list.html

Jmolデモ: http://ptmjmol.s3.amazonaws.com/section1/trace.html

画像ギャラリー: http://ptmgallery.s3.amazonaws.com/list.html

Amazonで本を買うためのアカウントを既にお持ちかも知れません。 もしまだアカウントをお持ちでないなら、https://www.amazon.com で案内に従いアカウントを作成して下さい(訳注:Amazon日本サイト https://www.amazon.co.jp とは別途アカウントが必要です)。 次に http://aws.amazon.com/console/ にアクセスして「サインアップ」からログインします。 画面右上「アカウント/コンソール」-「AWSマネージメントコンソール」をクリックしてコンソールを開き、「Storage & Contact Delivery」の「S3」をクリックします。

バケット(データの入れ物)を作成します。バケット名は全てのAWSデータセンター内で他と重複しないものにする必要があります。 「test」「mybucket」のような名前は既に使われていて新たに使うことはできないでしょう。 バケットには http://bucketname.s3.amazonaws.com のベースアドレスからアクセスできます。 http://s3.amazonaws.com/bucketname/ からもアクセス可能です。

S3コンソールを使うと次のような操作を行うことができます。 バケット作成、バケット内でのフォルダ・サブフォルダの作成、ファイルのアップロード・ダウンロード、ファイルのアクセス権や種類(Mime type)の設定、その他一般的なファイルシステムの管理(ファイル名の変更、ファイルの削除・切り取り・複製・貼り付けなど)。 また扱うファイルの数が多かったり、類似の操作を繰り返し行うような場合に、より効率的に操作を行えるようにするコマンドラインツールや画面ベースでのアプリケーション(下記参照)を利用することもできます。

バケット内で構造データファイルをJmolアップレットで扱えるようにするための配置方法は以下の通りです。

bucketname
  Jmol.js
  JmolApplet.js
  JmolApplet.jar
  JmolApplet0.jar
  JmolApplet0_Console/Minimize/Popup/ReadersCifPdb/ReadersMolXyz/ReadersMore/ReadersQuantum/ReadersSimple.jar
  JmolApplet0_ReadersXml/ReadersXtal/ShapeBio/ShapeSpecial/ShapeSurface/Smiles/Spectrum/Symmetry.jar
  section1
    mydemo.html
  models
    1GFL.pdb
    4E50.pdb
   

キーとなるスクリプトの設定は以下の通りです。

<html>
  ...  
  <script>
    jmolInitialize("..", window.location.protocol=="file:");  
    ...
    jmolApplet(600, "load ../models/1GFL.pdb");
    ...

バケット内において、全てファイルは通常だれでもアクセスできるようになっています。ファイルタイプはHTMLファイルの場合 text/html、画像ファイルの場合は image/png などとなっています。もしアップロードしたファイルが自動的にこのような設定にならなかった場合、プロパティ - Permissions/Metadata で修正できます。新たなバージョンのファイルをアップロードし直すとこれらの設定は簡単に失われてしまうことに注意して下さい。

ソフトウェアバージョンは以下の通りです:

 Jmol 13.0.18(S3バケットに上記 .js、.jar ファイルを配置)
 確認したブラウザ: Google Chrome 30.0, Firefox 24.0, Safari 5.1, Opera 12.16  
 開発の大半はMac OS X 10.6.8, java 1.6.0_51環境で、テストはMac OS 10.8.5、Windows 7環境で行いました。

S3バケット管理をより簡単にするためのフリーツールを以下に挙げます:

http://aws.amazon.com/developertools/739    ... コマンドラインツール
http://www.timkay.com/aws/                  ... 前項の別URL
http://s3browser.com/                       ... Windows用のS3バケット管理を行うGUIツール

Contributors

Cudo29, AngelHerraez